Hey Folks,
Having a tough period of studies and labbing, here i come with an interesting and probably very easy lab for the CCIE SP, but it is very interesting to understand and how to prevent from such during the lab.
Here i will talk a little about MPLS Auto-Configuration with different IGP in Cisco Platform, where we will see how to enable and how to prevent from the LDP sessions on un-required interfaces, so let’s begin:
The MPLS LDP Autoconfiguration feature enables you to globally configure Label Distribution Protocol (LDP) on every interface associated with a specified Interior Gateway Protocol (IGP) instance.
There are some restriction to enable the MPLS Autoconfiguration with Cisco which are:
- In Cisco IOS Release 12.2(33)SRB, the MPLS LDP Autoconfiguration feature is supported only with Open Shortest Path First (OSPF). Intermediate System to Intermediat System (IS-IS) is not supported.
- In Cisco IOS Release 12.0(32)SY, the mpls ldp autoconfig command is supported with OSPF and IS-IS interfaces. Other IGPs are not supported.
- If LDP is disabled globally, the mpls ldp autoconfig command fails and generates a console message explaining that LDP must first be enabled globally by means of the global mpls ip command.
- If the mpls ldp autoconfig command is configured for an IGP instance, you cannot issue the global no mpls ip command. To disable LDP, you must first issue the no mpls ldp autoconfig command.
- For interfaces running IS-IS processes, you can enable Multiprotocol Label Switching (MPLS) for each interface, using the router mode command mpls ldp autoconfig or mpls ldp igp autoconfig at the interface level.
- You specify that the default label distribution protocol is LDP for a router or for an interface. Tag Distribution Protocol (TDP) is not supported.
- The MPLS LDP Autoconfiguration feature is not supported on traffic engineering tunnel interfaces.
So seems that there are still many restriction available in this technology and honestly not sure that it will be completed or not but latest version of IOSs may resolve some of the restrictions, so let’s see the auto configuration mode in the Live lab environment:
NOTE: You must make sure to have this enabled very carefully on the Core network while your PE devices are facing the CE in which you don’t want to have the LDP session, for the P routers it is totally safe to enable auto-config since it is not directly connected with Customers. We will see how to prevent from such during the configuration.
We will use the following scenario all over the lab:
From the above topology we see that we have the Customer A who is having 2 different sites which are Site_A and Site_B and our scope is to provide the MPLS connectivity for the L3VPN in between these two sites.
Since we have discussed the initial configuration of all the devices separately in other posts here i will only show the initial configs so we can only concentrate on the lab.
Below are the Configuration on both CE:
CE1
!
Interface loopback 0
ip address 1.1.1.1 255.255.255.0
!
Interface Ethernet 0/0
description Link To PE1
ip address 10.1.12.1 255.255.255.0
!
router rip
version 2
no auto-summary
network 0.0.0.0
!
end
==
CE2
!
Interface loopback 0
ip address 8.8.8.8 255.255.255.0
!
Interface Ethernet 0/0
description Link To PE2
ip address 10.1.78.8 255.255.255.0
!
router rip
version 2
no auto-summary
network 0.0.0.0
!
end
==
For the simplicity we will run RIP as the IGP routing protocol in between these two sites and OSPF for the ISP, let’s see the PE1 and PE2 Configurations:
PE1
!
interface loopback 0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet 0/0
description Link To CE1
ip address 10.1.12.2 255.255.255.0
!
interface Ethernet 0/1
description Link To P1
ip address 10.1.23.2 255.255.255.0
!
interface Ethernet 0/2
description Link To P2
ip address 10.1.24.2 255.255.255.0
!
router ospf 1
network 0.0.0.0 0.0.0.0 area 0
!
end
==
PE1
!
interface loopback 0
ip address 7.7.7.7 255.255.255.255
!
interface Ethernet 0/0
description Link To CE2
ip address 10.1.12.2 255.255.255.0
!
interface Ethernet 0/1
description Link To P3
ip address 10.1.67.7 255.255.255.0
!
interface Ethernet 0/2
description Link To P4
ip address 10.1.57.7 255.255.255.0
!
router ospf 1
network 0.0.0.0 0.0.0.0 area 0
!
end
==
We will assign the interfaces to specific VRF later on.. Lets see the P routers configurations:
P1
!
interface loopback 0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet 0/0
description Link To PE1
ip address 10.1.23.3 255.255.255.0
!
interface Ethernet 0/1
description Link To P2
ip address 10.1.34.3 255.255.255.0
!
interface Ethernet 0/2
description Link To P3
ip address 10.1.36.3 255.255.255.0
!
router ospf 1
network 0.0.0.0 0.0.0.0 area 0
!
end
==
P2
!
interface loopback 0
ip address 4.4.4.4 255.255.255.255
!
interface Ethernet 0/0
description Link To PE1
ip address 10.1.24.4 255.255.255.0
!
interface Ethernet 0/1
description Link To P1
ip address 10.1.34.4 255.255.255.0
!
interface Ethernet 0/2
description Link To P3
ip address 10.1.46.4 255.255.255.0
!
interface Ethernet 0/3
description Link To P4
ip address 10.1.45.4 255.255.255.0
!
router ospf 1
network 0.0.0.0 0.0.0.0 area 0
!
end
==
P3
!
interface loopback 0
ip address 6.6.6.6 255.255.255.255
!
interface Ethernet 0/0
description Link To P1
ip address 10.1.36.6 255.255.255.0
!
interface Ethernet 0/1
description Link To P2
ip address 10.1.46.6 255.255.255.0
!
interface Ethernet 0/2
description Link To P4
ip address 10.1.56.6 255.255.255.0
!
interface Ethernet 0/3
description Link To PE2
ip address 10.1.67.6 255.255.255.0
!
router ospf 1
network 0.0.0.0 0.0.0.0 area 0
!
end
==
P4
!
interface loopback 0
ip address 5.5.5.5 255.255.255.255
!
interface Ethernet 0/0
description Link To P3
ip add 10.1.56.5 255.255.255.0
!
interface Ethernet 0/1
description Link To P2
ip address 10.1.45.5 255.255.255.0
!
interface Ethernet 0/2
description Link To PE2
ip add 10.1.57.5 255.255.255.0
!
router ospf 1
network 0.0.0.0 0.0.0.0 area 0
!
end
==
Now let’s configure the Client VRF Settings:
PE1
!
vrf definition Cust-A
rd 100:100
route-target both 100:100
address-family ipv4
!
interface Ethernet 0/0
vrf forwarding Cust-A
ip address 10.1.12.2 255.255.255.0
!
router rip
address-family ipv4 vrf Cust-A
network 10.1.12.0
version 2
no auto-summary
redistribute bgp 10 metric 2
!
router bgp 10
address-family ipv4 unicast
neighbor 7.7.7.7 remote 10
neighbor 7.7.7.7 update-source loopback 0
address-family vpnv4 unicast
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community both
address-family ipv4 vrf Cust-A
redistribute rip
!
end
==
PE2
!
vrf definition Cust-A
rd 100:100
route-target both 100:100
address-family ipv4
!
interface Ethernet 0/0
vrf forwarding Cust-A
ip address 10.1.78.7 255.255.255.0
!
router rip
address-family ipv4 vrf Cust-A
network 10.1.78.0
version 2
no auto-summary
redistribute bgp 10 metric 2
!
router bgp 10
address-family ipv4 unicast
neighbor 2.2.2.2 remote 10
neighbor 2.2.2.2 update-source loopback 0
address-family vpnv4 unicast
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
address-family ipv4 vrf Cust-A
redistribute rip
!
end
==
Now let’s enable the MPLS all over the Core and PE routers:
PE1 – P1 – P2 – P3 – P4 – PE2
!
ip cef
!
mpls label protocol ldp
mpls ldp router-id loopback 0
!
end
(Since our aim to have the MPLS Auto-Configuration we will not enable it under the specific interface)
Let’s see how we can enable MPLS auto configuration:
PE1
!
router ospf 1
mpls ldp autoconfig
!
end
After you added the above configuration you can see the result by typing the below command:
PE1#sh mpls interfaces
Interface IP Tunnel BGP Static Operational
Ethernet0/0 Yes (ldp) No No No Yes
Ethernet0/1 Yes (ldp) No No No Yes
Ethernet0/2 Yes (ldp) No No No Yes
PE1#
And you can see that the LDP session is running on all the interfaces who are directly connected with the client and P routers, (NOTE That this output of the SHow MPLS Interfaces only works when you didn’t assigned any interface under specific VRF Tables).
So how to overcome with such issue? let’s see how we can disable per interface:
PE1
!
interface Ethernet 0/0
no mpls ip
OR
interface Ethernet 0/0
no mpls ldp igp autoconfig
!
After you add above command you can re-verify as below:
PE1#show mpls interfaces
Interface IP Tunnel BGP Static Operational
Ethernet0/1 Yes (ldp) No No No Yes
Ethernet0/2 Yes (ldp) No No No Yes
PE1#
PE1#
Now you saw that the LDP session is disabled in the Interface facing the CE routers, and the same will work for the ISIS process. And also keep in mind that this tool is very powerful and should be treated seriously while designing any network. And i hope the above lab was helpful for you.
Cheers,