EtherChannel Technology allows us to bundle individual Ethernet links into a single logical link for high bandwidth. Cisco Devices support up to 8 interfaces to be bundled. However the bundled ports should be either FastEthernet or GigaEthernet ports and should be on same speed and duplex.

In bundled ports if one link is down due to any layer the traffic is propagated and transferred to another ports, which means our communication is not affected until they are under a common bundle.

There are two types of protocols which are used to bundle or aggregation of links together.

1. PAgP (Port Aggregation Protocol)  –  It is a Cisco Proprietary protocol

2. LACP (Link Aggregation protocol) –  It is IEEE Standard protocol

Below table shows the different options available which we can configure to create a EtherChannel.

Mode Protocol Description
Auto PAgP Interface starts the auto negotiation and also responds to PAgP negotiation packets.
Desirable PAgP Interface attempts to negotiate a PAgP connection if it receives any negotiation packets.
On EtherChannel Forces the creation of EtherChannel
Active LACP Interface starts the auto negotiation and also responds to LACP negotiation packets.
Passive LACP Interface attempts to negotiate a LACP connection if it receives any negotiation packets.

EtherChannel can be configured in two modes/layers which are layer 2 and layer 3. The main difference is that Layer 3 EtherChannel will use IP address under interface and the traffic will get routed between the two switches . In case of Layer 2 EtherChannel  traffic will get switched between the switches.

CONFIGURATION:

We will use following topology throughout this post:

POST ETHERCHANNEL

LAYER 2:

SWITCH 1:

SW1-SW(config)#interface range fa1/1 – 2
SW1-SW(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel1  ( SYSLOG MESSAGE APPEARS FOR INTERFACE )
SW1-SW(config-if-range)#switchport mode desirable
SW1-SW(config-if-range)#end

SWITCH 2:

SW2-SW(config)#interface range fa1/1 – 2
SW2-SW(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel1 ( SYSLOG MESSAGE APPEARS FOR INTERFACE )
SW2-SW(config-if-range)#switchport mode desirable
SW2-SW(config-if-range)#end

LAYER 3:

SWITCH 1:

SW1-SW(config)#interface port-channel 12
SW1-SW(config)#no switchport
SW1-SW(config)#ip address 1.1.12.1 255.255.255.0
SW1-SW(config)#interface range fa1/1 – 2
SW1-SW(config)#no switchport
SW1-SW(config)#channel-group 15 mode passive
SW1-SW(config)#end

SWITCH 2:

SW2-SW(config)#interface port-channel 21
SW2-SW(config)#no switchport
SW2-SW(config)#ip address 1.1.12.2 255.255.255.0
SW2-SW(config)#interface range fa1/1 – 2
SW2-SW(config)#no switchport
SW2-SW(config)#channel-group 15 mode active
SW2-SW(config)#end

VERIFICATION:

SW1

SW2

 

Cheers,

Print Friendly, PDF & Email